Register Login Rules
Search: 

Noggit user manual - Wiki

Noggit user manual

From Wiki

Jump to: navigation, search

This page is a user manual for NoggIt 3. Please create no links here. And only describe the usage of the app not the tech or creative background. This will be covered in other parts of the wiki.

Note that we also just rework this manual to fit with noggit 1.3. So it is in an inconsistent state in the moment.

Contents

Introduction

About

Noggit is a World of Warcraft map editor, based on an older version of WoWMapViewer. It allows you to edit the maptile files (called ADT files) with a set of tools using a 3D or a 2D view.

Noggit allows you to change the heightmap, paint textures, set impassible flags, paint AreaIDs and modify holes. You can also add, place, re-size, copy, paste, and delete models as you wish.

This document will give you an overview of all the Noggit functions, and how they work.

History

Originally Noggit was a project started by Cryect, also known from CryectsTools, which were needed aside from Noggit as Noggit missed alot of critical function to create your own world, such as adding water and objects. Yet Cryect stopped playing World of Warcraft around the release of the Burning Crusade expansion, this meant a stop to the development of Noggit aswell. A Russian named Beket was able to get his hands on the source code and started developing it for the 2.x.x versions of World of Warcraft. Yet he dropped out around Wrath of the Lich King, some time after Schlumpf recieved the source code, heavily bugged as it was. Since then it's been improved by Schlumpf, Tigurius and Steff, who are still working on it.

The source for 1.12 was published together with his tools after Nogg-Aholic died. There was no "getting your hands on the source" as it was public from that point onwards. Noggit3 is based on Beket's version, even if its not based on his latest version and some changes made by him have been removed again.


Getting started

Files you need

To use noggit you need a full installation of a 3.3.5a WoW client. It's a good idea to create a separate install for use with Nogg-It, so that as you create maps you can test the patches you made in a fresh client without the hazard of destroying the original MPQ files because of double opening. By default, Nogg-It saves ADT files in a folder within your World of Warcraft folder. If you test patchfiles you can get problems with overlaying the disc files and the one out of your MPQ.

To test MPQs it is best to have a clean WoW client without any other custom MPQs in and with cleared cache. I often get support questions that a patchfile doesn't work, this is often because there was some trash in cache or another custom MPQ inside the data folder that affects the new patch.

Windows: For the windows version you need to install the latest Visual Studio 2010 Runtime. You can download that here.

All other files are included in the binary release.

Mac:

Coming soon!

The config file

If you download noggit there is a file called Noggit_template included. This is a template for the noggit config file. To use it just rename it to Noggit.conf. Then it will be loaded and you can set some settings for noggit within it. We ship it with this name so that your config files don't get overwritten during updates.

It´s importand that the # character in front of a line marks this line as a comment. So all lines starting with this will be ignored by noggit. To use a config entry you must discard the # in front of this line. Here you can se an example for a config file:

# This is a config file tamplate. To use it rename into noggit.conf and set your optiones

#Edit this to your WoWFile!!!
Path = E:\WoW 3.3.5\

#Edit this to your Project-Directory and uncomment if you want to use it!
ProjectPath = E:\WoWModding\myProject\

#Set this to the file where you will impor models from (the modelviewer log for example :) )
ImportFile  = Path to ModelViewer logfile

#The Far clipping value. Set to 2048, 3072, 4096 etc. for a further look. Higher values need more 3d power.
#1024 is the standart value and will be taken if you do not set this value.
FarZ=4096


First of all, all paths MUST end with a \ character.

The first line called Path should be set to the directory of the WoW client that you want to use with noggit. This clinet should not have any custom MPQs inside the data folder, and again a empty cache. If you do not set this path noggit will try to get the path of the WoW client from your registry. But this could lead to problems if you have more then one client on your harddisk. Like a 3.3.5a and a 4 client.

The next setting ProjectPath gives you the possibility of setting the path where noggit will save files and load the files from a project folder. If this path is not set, noggit will save and load this stuff in the WoW client folder.

With the ImportFile option you can use the WoWModelViewer to easily search and import models into noggit. You must set this path to the Log.txt file inside the userSettings subfolder of your ModelViewer application folder. In the model section we discribe how this works in more detail. You can set this path as an alternative to all textfiles that include model paths in seperated lines.

The FarZ value set the distance how far noggit will display stuff in the 3D view. You can set this depending on the power of your graphics card. A higher value need more power and will render more models and ADTs. The possible values are 1024, 2048, 3072 and 4096. If you if you don't set anything here noggit will use a default value of 1024. This was the original value of the older noggit versions.

The Logfile

--- I WILL DO THIS AFTER THE LOGFILE CHANGES - STEFF --- SO DONT EDIT IT!!!! --- STEFF --OK!


If you have problems with noggit it is always a good idea to take a look in the logfile. Common errors are listed here and for the most problems you can find a solution on your own.

The first part of the Logfile gives you some informations about your configuration and environment.


Log example


Then you will see the start of the loading process opening the MPQs and the DBCs. Next noggit will take all the maps out of the Map.dbc and try to find the .wdt file in the MPQs. If a map hase no wdt it will not be listed in the main menu.

After that noggit will give out some messages depending on what you do with the application.

If you have a problem and cant fix it by yourself always add the logfile and the configfile to posts in the support board. Please always use http://pastebin.com/ for this to help prevent a overly long post. Here you can upload large text files and only post the link you get in the board. This helps keep our board DB clean.

Installation FAQ

Here i will collect some FAQ that help with common problems users had in the feature. If this problems are not gone because of recoding.

Main menu

The main menu

If you startup noggit you will get to the main menu. From here you can enter the map and the position on it you want to edit in different ways. On the Top of the screen you will see the menu bar.

File menu

You can exit noggit with this menu.


The map selector

With the next three menus you can select a map of the type the menu title is called. This will open a box with 64x64 possible maptiles on the center of the screen.

By clicking on an existing tile the map will start to load and you will enter the world at the selected position.
An open map menu
All existing tiles are painted in a solid gray. You also see an overlay of the WDL map if this file exists to find the right region on the map.

For custom maps you must create this file to see this.

On the bottom of the map you see the adt cords your mouse is currentyl over. So you can enter the map at a specific adt if you want.

Bookmarks

You can also select a map with the bookmarks menu. This menu exists only if you have at least one bookmakrs stored. If you have no or less bookmarks you will only see one menu. If you add more and more bookmarks you will get automatically up to 4 bookmark menus.

You can edit your bookmarks or delete some of them by editing the Bookmarks.txt file inside the noggit folder with any text editor.

If you click on a bookmark, noggit loads the map and you will enter the world at the saved position. Inside the 3D view you can save your current location py pressing F5.


The interface

Overview

Noggit3 got an expanded grafical user interface than older versions had. In the next lines we will introduce the different parts and give you an overview what they can do. If you need a more free look at the map, you can always hide and unhide the interface by pressing the Tabulator key.

Like in the old versions you can and should access many options also with keyboard shortcuts. You can always open up a window with importand shortcuts inside noggit by pressing the H(elp) key and you find the full list also in the appendix.

The noggit 3d editor interface


Menu bar

On the top of the screen you see a menu bar. Here you can access many options of noggit we will describe next.

The most functons can als be used with an key shortcut that is always written in front of the Menu option name in uppercase letters. Like CTRL + S for safe a tile in file menu.

Beside the menu you have the name and subname of the current zone. On the right side you see the current time witch will affect the light and sky you see in the editor.


The File menu

The file menu
  • CTRL + S Save - Save all files you changed since the last save or since you start noggit.

If you open up the map with M you can see all this tiles you have changed marked with a white border.


  • ESC Exit - Unload the current world and go back to main menu. All changes will be lost!


The edit menu

The edit menu
  • STRG + C copy - Copy the current selected model to the clipboard.
  • STRG + V past - Create a copy of the model in the clipboard on the current selected chunk.
  • DEL delete - deletes the currently selected object
  • CTRL + R - resets the rotation of the selected object
  • PAGE DOWN - sets the selcted model to the ground (a model from midair to groundlevel)
  • Copy random rotation - if this is checked and a model copied a random rotation will be copied
  • Copy random tile - should be called tilt and copies a random inclination of the model
  • Copy random size - if this is checked and a model copied a random size will be copied
  • Copy size and rotation - f this is checked and a model copied the rotation and size will be copied
  • Auto select mode - if the red triangle cursor is used and this is unchecked you can select single chunks


The assist menu

The assist menu

To add any model over the menu, you need to turn off auto selection mode and select a chunk before you use the meun option.

  • Last M2 from MV - loads the last known m2 model from log.txt.
  • Last WMO from MV - loads the kast known wmo model from log.txt.
  • From text file - opens a window with the modelnames of the models set in import.txt
  • To text file - writes the path of the selected model into import.txt
  • Helper models - open a window where you can add some helper models.
  • Set area ID - changes the area ID of the whole adt you are on to the selected ID
  • Clear height map - clears the height map of the adt you are on
  • Clear texture - deletes all textures(=tilesets) from the adt (it will appear white and no textures are painted)
  • Clear models - all models will be removed from the adt you are on
  • Clear water - clear the water layer on the current located adt.
  • Create water - Add a new water layer on ehight zero on the current located adt.


The view menu

The view menu
  • Toolbar - This toggles the toolbar on the right hand side
  • Current texture - If turned on this will pop up a window which shows the current texture
  • Texture palette - this toggles the texture window (can also be opened by clicking on the texture at the toolbar)
  • Cursor Options - This will open a option window for the cursor (shape can be changed (also by pressing c on your keyboard) and the colour)
  • Toggle - All options under this point will toggle the said functions (for example: "F1 M2's" will toggle the display of the M2's; this also can be achieved by pressing the F1 button on your keyboard - See also: http://modcraft.superparanoid.de/wiki/index.php5?title=Noggit_user_manual#Editor_options)


The help menu

The view menu
  • Key Binding - This will show a list of all keybindings in noggit
  • Manual online - Will open the User Manual for Noggit in your browser
  • Homepage - Will open the Modcraft Forum in your browser


Toolbar

The toolbar

The toolbar give you acces to the different tools to edit the world. Also you see the current selected texture in the bigger box on the bottom.

You can also switch the dfferent tools with the number keys.

You can hide this window with the close icon on the top right. To get it back just use the Toolbar entry in the view menu. Here you can also hide the toolbar again.

Left beside the close icon you can see your current selected editmode as a text representation. Then the different icons for the edit mode follow. The different edit modes will be latered explaind in detail. Here just an overview::

The tools

Raisen/Lower: Modify the height of the ground surface with different modes and brush sizes.

File:Flat.gif Flatten/Blure: Soften the ground surface with different modes and brush sizes.

File:Paint.gif 3D and 2D paint mode for textures. Depending on your current view mode.

File:Holes.gif Add and fill holes in the ground for passing through it. Needed for houses with basement or caves.

File:Areaid.gif Paint different AreaIDs on the surface. This is needet for the area text inside wow tha you can see over the minimap.

File:Impassible.gif Add and delete impassible flags on the ground. Chunks with this flag can a player not enter ingame.

File:WaterIcon.jpg Adjusting some values for the water added in noggit.

After the icons you see a box with the current selected texture. With a click on it you open up the texture browser to change the texture.

The texture selector

File:TilesetLoader.jpg

Status Bar

On the bottom of the noggit window U will find the status bar. This shows you some informations about our current position on the map.

It shows:

1. The current maptile you are located here 38_31,

2. The Client coordinates X,Y and Z.

3. The server coordinates X,Y and Z.

The last is the current paint mode. There are 2 modes build in that act different. To swap the mode use the CTRL and I.

Mode 1 always try to paint on top. Mode 2 paint on the layer that already have this texture if exist and dont overlay layers on top. Its ahrd to explain just try it.


File:InfoBar.jpg

Option windows

Some edit modes have special windows with options that affect the behavior of this tool. You can see them only if the correlate tool is selected. We will discripe them in the edit mode section.

Navigate the world

Navigating through maptiles/continents is fairly simple. First off, you must select a part of the continent that you would like to access from the main menu. Once you select a particular location, you will be shown the area in 3-dimensional space. From here, you can move throughout the world with the following controls:

Keyboard controls

W - Forwards

S - Backwards

A - Move/Strafe Left

D - Move/Strafe Right

Q - Ascend

E - Descend

R - Turn your view 180 degrees around the X-axis

P - Increase Movement Speed

O - Decrease Movement Speed

I - Invert Camera Y-axis Movement

M - View Minimap

Shift +1 till 4 - Set the current Movement Speed to on of 4 fixed values.

Mouse controls

Right-click turns the camera view while the button is held down.

Right and left mouse buttons together moves the camera forward. You can also navigate by pressing the hotkey W (move forward) and steer using right-mouse button.

Navigation map

If you press M the navigation map you have also uset to load the map comes up and overlays the 3D editor. Here you can see your current location and view direction, marked by a white line. You can also jump to any ADT by just click on this one in the map.

All on the map existing ADTs have here a square Orange marked once are located and loaded from harddisct and not from MPQ. So you can see already edited ADTs on an map located in an MPQ.

If an WDL file for the map exist, it will be used to render a contour map beind the ADT squares.

The white dots are light sources from the Light.dbc. They get only displayed. You can not edit them here.

File:MapSelector.jpg

Editor options

View options

In the View menu you can turn on/off some display settings.

Maptile elements

This options turn the rendering of some elements of the maptiles on or off. FOr example the water rendering or if M2 models are displayed.

F1 - Enable/disable display of M2 objects

F2 - Enable/disable display of WMO doodadsets

F3 - Enable/disable display of ground surface

F4 - Enable/disable display of water

F6 - Enable/disable display of WMO objects

Visual helpers

There are some additional visual helper informations you can turn on to make it easyer to edit the maptiles.

F7 - Enable/disable display of border lines. THis lines show you the technical boarders of the Maptile

  • red squares are chunks
  • green are the maptiles (ADTs)
  • blue are the subchunks

You see the blue lines only if you activat them over the view menu or if you are in the hole mode. Hols just turn of subchunk rendering.


File:Lines.jpg

F9 - Enable/disable display of map contours

The contours or height lines render horizontal lines to visualize the height differences of the ground.

File:HeightLines.jpg

Shift and F1. This is a special Function to setup the editor environment for best ground editing. It will turn all unnecessary display options like M2s or WMOs and turn on the map contour. If you press again you will get your last view settings back.


Cursor types

By pressing the C key you can switch the cursor type. There are 4 different modes:

  • circle with center point.
  • Sphere with center point.
  • Triangle.
  • No cursor rendering.

File:CursorTypes.jpg

Models

Select and move models

To select an object just click on it in the 3D view. Around the selected object you will see one or more white boxes and some colored lines. The with boxes are the bounding boxes of the model and the lines mark the rotation axis for x,y and z origion of it.

With mouse assistance

The movement of M2 and WMO models with the mouse are the same. But sizing work only with M2s because the WMO format dont support scaling.

  • Shift + Right-click + Mouse-movement (sideways): Rotate the object in a circle, following the Z-axis
  • Shift + Middlemouse + Mouse-movement (up/down): Moves the object up and down, depending on mouse movement
  • CTRL + Right-click + Mouse-movement (sideways): Rotates the object, following the X-axis (red line linked to object)
  • CTRL + Middlemouse + Mouse-movement (any): Moves the object, following the Z and Y-axis
  • ALT + Right-click + Mouse-movement (sideways): Rotates the object, following the Y-axis (blue line linked to object)
  • M2:ALT + Middlemouse + Mouse-movement (up/down): Scales the object, increasing size by moving the mouse upwards, decreasing, if moving the mouse downwards
  • WMO:ALT + Middlemouse + Mouse-movement (any): Moves the object, following the Z and X-axis

Only with keyboard (numpad)

You can also modify the most position and scaling values with the numpad on the keyboard without using the mouse.

  • + and - scale the model.
  • 4, 8, 6 and 3 change the position of the model on the ground in x and y direction.
  • 7 and 8 change the up/down (z axis) position of the selected model.
  • 1 and 2 rotate the model on z axis.

Special keys

  • The Page Down key set a model with his origin to the ground level.
  • The key combination Shift and R reset all rotation and panning values to 0.
  • If you select a WMO you can change the doodadset by pressing 1 to 9.

Copy, paste and delete

To copy a WMO or M2 just select it and press CTRL + c or select the menu Edit > copy. Then move the mouse pointer to the ground position you want to insert the copy and press CRTL + v or select the menu Edit > paste. To use the menu you have to turn off the auto selection mode by pressing Shift and F4. Now the chunk selection triangle dont follow the mouse. You can set it with a click on a chunk.The model will be inserted with it's base point located at the cords of the mouse and set to the ground level.The rotation and pan values get reset to 0.If you want to quickly create many copies of a model you can use the auto variation options. This will auto size, pan and/or rotate the copy of the model. You will find the 3 options in the edit menu and can activate them individually.To delete a model just select it and press the DEL key on the keyboard or select edit > delete in the menu.

Add models

You have several options to add models to the current map.For all ways you must first select a chunk to locate the position the model(s) will be placed.For this task turn off the auto selection mode with Shift + F4 or over the edit menu and select a chunk on the ground.The yellow triangle must stay on the selected chunk!

Import.txt

Place a normal text file inside the noggit directory and just insert all the pathes of the M2s and WMOs you want to add.Every path must be located in a new line. Now select Menu > Assist > from textfile. All models will be added on your selected locations. Noggit only add models that are realy exist in the MPQ files.

File:ModelFromtxtFile.jpg

From Modelviewer

To use this option you must set the path to the ModelViewer log file inside the noggit config file.This path must point to the Log.txt file inside the userSettings subdirectory of the Viewers application path.

For Example:ImportFile = c:\WoWTools\ModelViewer\userSettings\Log.txt

Now you have 3 options to insert models from the Viewer. Load the Modelviewer and select one ore mode models, now go to noggit, select a chunk and choose one of the following option in the Assist menu.

  • All form Modelviewer - Will import ALL models you opend since the last start of the viewer.
  • Last M2 form Modelviewer - Will only import the last selected M2 model.
  • Last WMO from Modelviewer - Will only import the last selected WMO model.

The fixed helper models

You will find some test and scaling models in the menu. If you select this otion, a window will open up where you can select the models. You must have a chunck selecte to add a model. So You must switch autoselection Off with Shift F4.

The terrain edit modes

Now we will take a look at the different tools to modify the ground. You can activate them by pressing the correlate icon in the toolbar. THe current activ tool is marked with a shiny border around the icon.

File:Raisen.gif Raise/Lower

Ctrl + Left Mouse Button will lower the terrain in which the cursor is located on.

Shift + Left Mouse Button will raise the terrain in which the cursor is located on.

File:RaisenLower.jpg

The different speeds and radius in which the tool works can be configured at the top-right of Noggit, within the option box. The box also includes different variations of raising/lowering the terrain such as: Flat (will raise/lower terrain with a specified radius, in a cylinder-like shape), Linear (will raise/lower terrain from a point that extends to radius, in a cone-like shape), and Smooth (will raise/lower terrain smoothly/without as many jagged edges, in a dull-crayon-top-like shape).

File:Flat.gif Flatten/Blur

Shift + Left Mouse Button will flatten the area around the cursor (from below and above) to be the same height level as it.

Ctrl + Left Mouse Button will blur the area around the cursor to create an average height level between two different heights (ie. a "middle" height).

File:FlattenBlur.jpg

The different radius in which the tool can be used in can be configured at the top-right of Noggit, within the option box. The box also includes different variations of flattening/blurring the terrain such as: Flat (flattens/blurs faster than other variations, and is more precise; allows easiest creation of flat plains/valleys beside mountains), Linear (flattens/blurs slower than flat, but faster than smooth; allows easiest creation of walkable slopes/hills), and Smooth (flattens/blurs slower than other variations, allowing for 'smoother' slopes and terrain; allows easiest creation of beaches or smooth dunes/mounds on the ground).

File:Paint.gif Texture paint

Key bindings

You can paint textures in both view modes (3D and 2D).

  • Shift + Left Mouse Button will paint the texture you have currently selected.
  • Shift, Alt and CTRL + Left Mouse Button will erase all texture layers from the clicked chunk. The first paint on this chunk will fill the first layer completely with the current selected texture.
  • CTRL + Left Mouse Button click on a chunk open up a smale windows that displays all textures that exist on this chunk. You get max 4 textures here and with a click on one of them this texture ges set as current selected texture for painting.

File:TexturePicker.jpg

Also there are 2 different modes for texture painting. You can see what mode is activ in the status bar. PM1 or PM2. To swap the mode use the CTRL and I.Mode 1 always try to paint on top. Mode 2 paint on the layer that already have this texture if exist and dont overlay layers on top. Its ahrd to explain just try it.


The texture tool has several options located in the options window. These options include the following:

Paint Options

File:PaintOptions.jpg

  • Hardness (how defined the texture will be on the terrain; the lower the hardness, the softer/blurrier the texture),
  • Brushsize - The size of the cricle you paint with.
  • Pressure (how strongly the texture is applied to the terrain; the lower the pressure, the more faint/subtle the texture),
  • Texture Translucency Scale - This Scale allows you to change the translucency (visibility) of the texture you are applying; from white (completely opaque/visible) to black (completely translucent/invisible) and anywhere in between on the scale. This scale is useful for setting a maximum visibility of a texture, for example to blend one texture to another. It can also be used to erase the selected texture, or have it reappear if another texture is 'on top'.


Texture swapper

File:TextureSwapper.jpg

There is also a texture swapper to swap textures on a chunk or on a full ADT. First activate the swapper by pressing the Texture swapper button in the paint options. Now select your texture you want to swap with the picker or over the texture pallet.

Next press the set destination button to set this texture. After this select the texture that you want to have after the swap.

Just use Shift to paint the swap on the wanted chunks. Or you use the swap ADT button to swap the full ADT you are now located on with the camera.

File:Holes.gif Holes Tool

The Holes tool is used to create holes in specific areas within the ADT to let players access WMOs that are placed within/through terrain. Since most WMOs have entrances, they will be blocked by terrain that should be removed accordingly (with this tool).Ctrl + Left Mouse Button removes the selected chunk from the ADT.Shift + Left Mouse Button adds the selected chunk back into its place.

File:Areaid.gif AreaID Paint

Every chunk on an ADT can have its own Area ID. These IDs are found in the AreaTable.dbc [1] file, which handles the name displayed over the minimap and many other area-specific things like zone music. Every AreaID is painted in a different random color.

File:AreaIDBrowser.jpg

To select an AreaID for painting, select the AreaID paint tool from the toolbox and press X. This will open the AreaID browser, where you can browse through and select any of the AreaIDs assigned to the currently open map in AreaTable.dbc [2]. Clicking on any of the displayed IDs will show a list of relevant subzones. The button in the top right corner of the browser will return you to primary zone selection. You can also select any chunk's AreaID by CTRL-clicking it.

Painting AreaIDs is very simple. After selecting your desired AreaID, just SHIFT-click every chunk you wish to set the AreaID of. Each chunk's color will change when you successfully change its AreaID.


Note: Subzones should only be painted within larger surrounding zones.

File:Impassible.gif Impassible paint

With this tool you can set the impassible flag on a chunk, which will prevent players from walking on it. Impassible chunks can be used as invisible walls to prevent players from going places where they shouldn't be. Flagged chunks are overlaid with a white square.

  • SHIFT + clicking - a chunk will flag it as impassible
  • CTRL + clicking - it will clear the flag.


FIle:WaterIcon.jpg Water Edit

When water is created in noggit you are able to set/change some values of the water with following options:

File:WaterOptions.jpg

  • Opacity: This bar adjusts the opacity level on the whole adt.
  • evel: With the buttons from -100 to +100 you can move the water the shown number of units up and down (- euqals down and + equals up)
  • 0 - Unkown type: By clicking on that a new windwo will open with all liquid types. Here you can choose type of liquid for the adt you are currently on.
  • Opacity Gen Factor: Here you can adjust the value of the auto opacity
  • Auto opacity: This generates automatically oppacity based on the waterdeepth on the current adt.

appendix

Bookmarks

If you hit F5 on a loaded map, noggit3 stores your current location including the AreaName inside the Bookmarks.txt file. All entrys of this file get listed inside the main menu in up to 3 bookamrks menus. The only appeare if there is minimum one bookmark stored. Just clikc on the entry to get to your work again. You can edit the bookmakrs.txt file to delete entrys or just rename them to find them faster.

Getting teleport commands

Because its a mess to get fast to a place you have just created inside of noggit on the server, I have implemented an autocreate teleport command function. Just go inside of noggit to the place you want to get ingame. Then hit the g button on your keyboard. Noggit now create the port commands for ArcEmu and Trinity and write them at the end of the file ports.txt inside your wow folder. Just copy the command fitting to your Emulator and past it inside your WoW client. Here a short example line form my ports.txt file.

Map: Meberian Continent on ADT 20 20

Trinity:
.go 6364.32 6374.55 20.0482 606

ArcEmu:
.worldport 606 6364.32 6374.55 20.0482 

Shortcut list

Basic controls:

  • Left mouse dragged - Rotate camera
  • Left mouse click - Select chunk or object
  • Both mouse buttons - Move forward
  • I - Invert mouse up and down
  • Q, E - Move vertically up, down
  • A, D, W, S - Move left, right, forward, backward
  • C - Switch cursor type
  • M - Show map
  • U - 2D texture editor
  • H - Open help screen with list of comands
  • CTRL + ALT + C - Toggle cursor options
  • SHIFT + R - Turn camera 180 degres
  • SHIFT + F4 - Change to auto select mode
  • SHIFT + 1, 2, 3 or 4 - Set a predefined speed
  • ESC - exit to main menu

Toggles:

  • F1 - Toggle M2s
  • F2 - Toggle WMO doodads set
  • F3 - Toggle ground
  • F4 - Toggle water
  • F6 - Toggle WMOs
  • F7 - Toggle chunk (red) and ADT (green) lines
  • F8 - Toggle detailed window
  • F9 - Toggle map contour
  • F - Toggle fog
  • TAB - toggle UI view
  • X - Toggle tool settings
  • CTRL + X - detail window
  • 1,2,3,4,5 and 6 - Select the editing modes

Files:

  • F5 - save bookmark
  • F10 - reload BLP
  • F11 - reload M2s
  • F12 - reload wmo
  • SHIFT + J - reload ADT tile
  • CTRL + S - Save all changed ADT tiles
  • CTRL + SHIFT + S - Save ADT tile at camera position
  • g - Save port commands to ports.txt

Adjust:

  • O / P - slower/faster movement
  • B / N - slower/faster time
  • SHIFT + +/-: fog distance when no model is selected

Edit ground:

  • SHIFT + F1 - toggle ground edit mode
  • ALT + left mouse + mouse move - change brush size
  • Z - Change the mode in option window

Terrain mode raise / lower

  • SHIFT + Left mouse - raise terrain
  • CTRL + Left mouse - lower terrain

Terrain mode flatten / blur

  • SHIFT + Left mouse click - flatten terrain
  • CTRL + Left mouse click - blur terrain

Edit objects if a model is selected:

  • Hold middle mouse - move object
  • ALT + Hold middle mouse - scale M2
  • SHIFT / CTRL / ALT + Hold left mouse - rotate object
  • 0 - 9 - change doodads set of selected WMO
  • CTRL + R - Reset rotation
  • PageDown - Set object to Groundlevel
  • CTRL + C - Copy object to clipboard
  • CTRL + V - Paste object on mouse position
  • SHIFT + C - Insert last M2 from MV
  • ALT + C - Insert last WMO from MV
  • - / + - scale M2
  • Numpad 7 / 9 - rotate object
  • Numpad 4 / 8 / 6 / 2 - vertical position
  • Numpad 1 / 3 - move up/dow
  • holding SHIFT: double speed
  • holding CTRL: triple speed
  • holding SHIFT and CTRL together: half speed

Edit texture:

  • CTRL + SHIFT + left mouse - clear all textures on chunk
  • CTRL + left mouse - draw texture or fills if chunk is empty

Holes:

  • SHIFT + Left mouse - Add hole
  • CTRL + Left mouse - Remove hole

AreaID:

  • X - Show browser with existing AreaID in AreaTable.dbc
  • CTRL + Left mouse - Pick existing AreaID from chunk
  • SHIFT + Left mouse - Paint selected AreaID
  • Impassible tool:
  • SHIFT + Left mouse - Paint flag
  • CTRL + Left mouse - Clear flag